Product Updates Information about Product Updates from Inishtech
InishTech Support Forums > Product Updates > Code Protector Update - Version 3.0.1912 Login to add this as a favourite.
User avatar
Site admin
Site admin
Admin - 10/19/2010 11:02:40 AM
Code Protector Update - Version 3.0.1912

Thursday 21st October 2010:  New version of Code Protector released with support for .NET Framework 4.0

.NET Framework 4.0 Support

With the release of 3.0.1912 of Code Protector and associated Runtime DLLs it is now possible to transparently protect assemblies targetting the 4.0 CLR without requiring changes to one's build scripts or .SLMCfg files.

The following details are for information only and summarise some recent updates and clarifications:-

  • The runtime DLLs continue to have 2.0 suffixes (and do not themselves require CLR 4.0)
  • A number of constructs specific to CLR 4.0, such as dynamic, are not supported at present (attempts to protect such code will result in an error message). It is anticipated that this restriction will be removed in time.
  • The list of unsupported constructs is not affected by this update (removal of key restrictions on usage of generic types for both 4.0 and 2.0 CLRs is in beta at present).
  • There remains just one edition of the SDK and Protector applications, i.e., there is not a separate 4.0 edition or a separate 64 bit edition.
  • As with all releases after 3.0.1911, there are no longer a separate set of 'versioned' assemblies - the 'unversioned' work as one would expect, being isolated from other versions in the GAC etc.

Additional troubleshooting details (again, for information only - it is not anticipated that this information is required for normal usage):

  • The Code Protector application, the commandline equivalent and protection via SLPS_PROTECT all require the 4.0 CLR to be installed on the machine on which the protection will be performed if an assembly targetting CLR 4.0 is included in the set of assemlies in one's .SLMCfg Project. (For information only: The tools themselves run under the 4.0 CLR, even when protecting assemblies that only require CLR 2.0 - this is accomplished via a <supportedRuntime> entry in the exe.config file - this allows a single installer to work on machines with 2.0, 4.0 or both CLRs present. In the case where both are present, 4.0 is preferred)


There are currently no users on-line.

  • Sticky
  • Locked sticky
  • Hot sticky
  • Hot locked sticky
  • Thread
  • Hot thread
  • Locked thread